How To Create an Arista Multi-Chassis Link Aggregation (MLAG) Domain

Arista is a software company that produces enterprise grade switches for the datacenter. MLAG stands for Multi-Chassis Link Aggregation and allows two switches to act like a single switch to allow LACP over separate switches for redundancy. Cisco calls this vPC, Brocade calls this MCT, Force10 calls this VLT, every vendor has their own method of mutli-switch lag redundancy and since each company’s implementation is different, you cannot cross vendor LAG switches. This quick tutorial is how to create an MLAG domain between two Arista switches.

eos4-3

Prerequisites

  • 2x Arista Switches with same firmware on both
  • 2x Network Connections connected between each switch (Peer Links)

1. Create Port Channel For Peer Links

  • We are using 7048T switches with 2x 10Gb Ethernet as our peer links. On each switch we will create a port channel 998 and include these links
switch1# config t
switch1(conf)#interface e51-52
switch1(config-if-Et51-52)# channel-group 998 mode active
switch1(config-if-Et51-52)# interface port-channel 998
switch1(config-if-Po998)# switchport mode trunk

2. Create a VLAN for Peer MLAG Communication

  • In this step we will create a separate VLAN for MLAG communication and assign it the mlagpeer trunk group and disable spanning-tree on the vlan. This step is done on both switches
switch1(conf)#vlan 998
switch1(config-vlan-998)# trunk group mlagpeer
switch1(config-vlan-998)# interface port-channel 998
switch1(config-if-Po998)# switchport trunk group mlagpeer
switch1(config-if-Po998)# exit
switch1(conf)#no spanning-tree vlan 998

 

3. Set Interface IP for each switch to communicate

  • For VLAN 998 that we created, we will assign it an IP so each switch can communicate with each other
switch1(conf)#int vlan 998

switch1(config-if-Vl998)# ip address 10.0.0.1/30

 

switch2(conf)#int vlan 998

switch2(config-if-Vl998)# ip address 10.0.0.2/30
  • Ping each switch to see if they have connectivity together

 

4. Configure MLAG peering for each switch

switch1(config)#mlag
switch1(config-mlag)#local-interface vlan 998
switch1(config-mlag)#peer-address 10.0.0.2
switch1(config-mlag)#peer-link port-channel 998
switch1(config-mlag)#domain-id MLAGDOMAIN

 

switch2(config)#mlag
switch2(config-mlag)#local-interface vlan 4094
switch2(config-mlag)#peer-address 10.0.0.1
switch2(config-mlag)#peer-link port-channel 10
switch2(config-mlag)#domain-id MLAGDOMAIN

 

5. Verify MLAG Domain

  • On each switch, do a show mlag to see if MLAG is up and running

switch1(config-mlag)#show mlag
MLAG Configuration:
domain-id : MLAGDOMAIN
local-interface : Vlan998
peer-address : 10.0.0.2
peer-link : Port-Channel998

MLAG Status:
state : Active
negotiation status : Connected
peer-link status : Up
local-int status : Up
system-id : 02:1c:73:62:72:61

MLAG Ports:
Disabled : 0
Configured : 0
Inactive : 0
Active-partial : 0
Active-full : 0

 

switch2(config-mlag)#show mlag
MLAG Configuration:
domain-id : MLAGDOMAIN
local-interface : Vlan998
peer-address : 10.0.0.1
peer-link : Port-Channel998

MLAG Status:
state : Active
negotiation status : Connected
peer-link status : Up
local-int status : Up
system-id : 02:1c:73:62:72:61

MLAG Ports:
Disabled : 0
Configured : 0
Inactive : 0
Active-partial : 0
Active-full : 0

 

 

 

Leave a Comment